Problem C

Truss Frame

Steel Frame

E =29000 ksi, Poissons Ratio = 0.3

All steel members are L4x4 angles, Fy = 36ksi
Base is pinned

Diaphragms
Concrete diaphragms are 8” thick with a unit weight of 150 pcf

Model as rigid diaphragm at Levels A and B
Additional dead load at each diaphragm is 50 psf
Live load at each diaphragm is 100 psf

To Do
Size steel members for DL + LL using AISC - ASD89
Determine the first three modes of vibration
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(All four sides are the same)

Note: Our intent isthat you try this problem on your own first. After you have solved it on your
own, you can step through our solution if desired. If you have problemstrying to create the
model, then follow the stepsin our solution.



Problem C Solution

1.  Click the drop down box in the status bar to change the units to kip-ft. [kip-# -l

2. Fromthe File menu select New Model.... This displays the Coordinate System Definition
dialog box.

3. Inthisdialog box

Select the Cartesian Tab.

In the Number of Grid Spaces areatype 0 in the X direction edit box.
In the Number of Grid Spaces areatype O inthe Y direction edit box.
In the Number of Grid Spaces areatype 0 in the Z direction edit box.

Click the OK button.

4.  Fromthe Draw menu select Edit Grid... to display the Modify Grid Lines dialog box.

5. Inthisdialog box:

Verify that the X option is selected in the Direction area.

Type 7 inthe X Location edit box and click the Add Grid Line button.
Type 10.5in the X Location edit box and click the Add Grid Line button.
Select the Z option in the Direction area.

Type 25in the Z Location edit box and click the Add Grid Line button.
Type 37 inthe Z Location edit box and click the Add Grid Line button.

Click the OK button.

6. Click inthewindow titled X-Y Plane @ Z=0 to make sure it is active. The window is
highlighted when it is active.

7. Click thexz 2D Viewbutton| =] to change the view to an X-Z elevation. Notethat the
title of the window changes to X-Z Plane @ Y =0.
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Figure C-1: Initial Grid Layout In X-Z Plane

8.  Click the Quick Draw Frame Element buttonz on the side toolbar or select Quick
Draw Frame Element fromthe Draw menu. =~

9. Click on the grid line at the point labeled “A” in Figure C-1 to enter a frame element.
10. Click on the grid line at the point labeled “B” in Figure C-1 to enter another frame element.

11. Click theDraw Frame Element buttorg on the side toolbar or selBcaw Frame
Element from theDraw menu. _

12. Click on the points labeled “C”, “D”, and “E” in Figure C-1, in that order, and then press
the Enter key on the keyboard to draw two more frame elements.

13. Click on the point labeled “F’ and then double click the point labeled “E” in Figure C-1 to
draw the next frame element.

Note: You could have single-clicked the point labeled “E” in Figure C-1 and then pressed
the Enter key on the keyboard to finish drawing the frame element.



14. Click on the point labeled “G” and then double click the point labeled “D” in Figure C-1 to
draw the next frame element.

15. Click on the point labeled “D” and then double click the point labeled “F” in Figure C-1 to
draw the next frame element.

16. Click thePointer buttorﬁl to exit Draw Mode and enter Select Mode.

17. Click theSet Elements buttoriﬁl on the main toolbar (or sel8et Elements.. from the
View menu) to display the Set Elements Dialog box.

18. Inthisdialog box:
» Check the Labels box in the Joints area.
» Check the Labels box in the Frames area.
» Check the Fill Elements box.

* Click the OK button. The screen appears as shown in Figure C-2.
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Figure C-2: Screen As |t Appears After Step 18
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Click on frame elements 1 and 3 to select them.

From the Edit menu select Divide Frames... to

display the Divide Selected Frames dialog box.

Verify that this dialog box is filled out as shown & Diideinto | Frames
in the adjacent figure and click the OK button. Lst/Firstratio ||

Click the Draw Frame Element button =] on ~ Break atintersections with selected
the side toolbar or select Draw Frame ETement Frames and Jaints

from the Draw menu.

[ ok ]

Cancel

Click on joint 9 and then double click on joint 13

to draw aframe element.
Click on joint 8 and then double click on joint 12 to draw a frame element.
Click on joint 7 and then double click on joint 11 to draw a frame element.
Click on joint 6 and then double click on joint 10 to draw a frame element.
Click on joint 13 and then double click on joint 2 to draw a frame element.
Click on joint 12 and then double click on joint 9 to draw a frame element.
Click on joint 11 and then double click on joint 8 to draw a frame element.
Click on joint 10 and then double click on joint 7 to draw a frame element.
Click the Pointer button ﬁl to exit Draw Mode and enter Select Mode.
Click inthe 3D View window to activate it.

From the View menu select Refresh View to rescale the view.

Click in the Window labeled X-Z Plane @ Y =0 to activate it.

Click the Select All button on the side toolbar to select al elements.

From the Edit menu select Replicate... to display the Replicate dialog box.

In this dialog box:
* Select the Mirror Tab.
* Inthe Mirror About area select Y-Z plane.

* Inthe Ordinate areatype 10.5 in the X edit box.
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* Click the OK button to proceed with the replication.

Click the Draw Frame Element buttong on the side toolbar or select Draw Frame
Element from the Draw menu. _

Click on joint 4 and then double click on joint 16 to draw a frame element.

Note: If thefont sizeistoo small for you to read the joint labels use the following
procedure to increase the font size. From the Options menu select Preferences, click
on the Dimensions Tab if it isnot already visible, type in a new (larger) font sizein the
Minimum Graphic Font Sze edit box (usually about 6 pointsis sufficient), click the OK
button and then click the Refresh Window button | # | on the main toolbar.

Note: If you till have difficulty reading a particular joint label you can always right click
the joint to bring up a dialog box that gives you information about the joint.

Click the Pointer button ﬁl to exit Draw Mode and enter Select Mode.
Click the Select All button &ll| on the side toolbar to select all elements.
From the Edit menu select Replicate... to display the Replicate dialog box.
In this dialog box:

» Select the Radial Tab.

* Inthe Rotate About area select the Z Axis option.

* Inthe Increment Data area verify that the Angle is 90 and the Number is 1.
* Click the OK button to proceed with the replication.

Click the Restore Previous Selection button | on the side toolbar.

From the Edit menu select Replicate... to display the Replicate dialog box.
In this dialog box:

» Veify theLinear Tab is selected.

* Inthe Distance areatype 21 inthe Y edit box.

* Veify that Oisentered in the X and Z edit boxes.

» Veify that 1 isentered in the Number edit box.

* Click the OK button to proceed with the replication.

Click in the window titled X-Z Plane @ Y =0 to make sure it is active.
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Click theyz 2D View button| sz | to change the view to an Y-Z elevation. Notethat thetitle
of the window changesto Y-Z Plane @ X=0.

Select all of the elements in the Y-Z plane @ X=0 by “windowing”.
From theEdit menu selecReplicate... to display the Replicate dialog box.
In this dialog box:

» Verify the Linear Tab is selected.

* Inthe Distance area ty@ in the X edit box.

* Inthe Distance area tyfein the Y edit box.

» Verify that 0 is entered in the Z edit box.

» Verify that 1 is entered in the Number edit box.

* Click theOK button to proceed with the replication.

Click thexy 2D View buttor] | to change the view to an X-Y plan. Note that the title of
the window changes to X-Y Plane @ Z=0.

Select the four joints at this level either by “windowing” or by clicking on them
individually.

From theAssign menu, chooséoint, and therRestraints...from the submenu. Thiswill
display the Joint Restraints dialog box.

In this dialog box:
* Veify that the Translation 1, Translation 2 and Translation 3 boxes are checked.

» Veify that the Rotation About 1, Rotation About 2 and Rotation About 3 boxes are not
checked.

e Click the OK button.

Click the Show Undeformed Shapéutton g to reset the window display from joint
restraints to undeformed geometry. Notethat the window title changes.

Click the Up One Gridline buttoni| on the main toolbar to display the elevation view at
Z=25.

Click the Draw Rectangular Shell Elemembuttonﬂ on the side toolbar or select Draw
Rectangular Shell Elementfrom the Draw menu.

Click on joint 32 and then joint 14 to draw a shell element over the entire structure.
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Click the Pointer buttonﬁl to exit Draw Mode and enter Select Mode.

Click on the shell element to select it.
From the Edit menu select M esh Shells... to
display the Mesh Selected Shells dialog box. & Mesh into E
. . 3
Fill in this dialog box as shown in the adjacent o |' shells
figure and click the OK button. " Mesh using selected Joints on edges
" hesh atintersection with grids

Click the Up One Gridline button 4 [onthe '
main toolbar to display the elevation view at ok | Cancel |
Z=31.

Click the Draw Rectangular Shell Element buttonE‘ on the side toolbar or select Draw
Rectangular Shell Element from the Draw menu.

Click on joint 33 and then joint 15 to draw a shell element over the entire structure.

Click the Pointer buttonﬁl to exit Draw Mode and enter Select Mode.

Click on the shell element to select it.
From the Edit menu select Mesh Shéells... to
display the Mesh Selected Shells dialog box. ' Mesh into B

by [2 Shells

Fill in this dialog box as shown in the adjacent
figure and click the OK button.

" Mesh using selected Joints on edges

" hesh atintersection with grids

Click the Set Elements button|§| on the main
toolbar (or select Set Elements.. from the View ok | el
menu) to display the Set Elements Dialog box.

In this dialog box:

» Uncheck the Labels box in the Joints area.

» Uncheck the Labels box in the Frames area.
» Click the OK button.

From the Define menu select Static Load Cases.... Thiswill display the Define Static
Load Case Names dialog box.

In this dialog box:
* TypeDL inthe Load edit box.

» Click the Change Loadbutton
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 TypelLL inthe Load edit box.

» Select LIVE from the Type drop-down box.

» TypeOinthe Self weight Multiplier box.

» Click the Add New L oad button.

* Click the OK button.

From the Define menu select M aterials... to display the Define Materials dialog box.
In this dialog box:

» Highlight the CONC material and click the M odify/Show M aterial button to display
the Material Property Data dialog box.

* Inthisdialog box:

» Verify that the Mass per Unit Volume is 4.658E-03.

» Verify that the Weight per Unit Volume is 0.15.

» Click the OK button twice to exit all dialog boxes.
Click the drop down box in the status bar to change the unitsto kip-in. [kiein =]
From the Define menu select M aterials... to display the Define Materials dialog box.
In this dialog box:

» Highlight the STEEL material and click the M odify/Show M aterial button to display
the Material Property Data dialog box.

* Inthisdialog box:
» Verify that the Modulus of Elasticity is 29000.
» Verify that Poisson’s ratio is 0.3.
» Verify that the steel yield stress is 36.
» Click theOK button twice to exit the dialog boxes.

From theDefine menu selecErame Sections... to display the Define Frame Sections
dialog box.

In this dialog box:
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Click the drop-down box that says Import 1/Wide Flange and select the Import Angle
option.

If the Section Property File dialog box appears then locate the Sections.pro file which
should be located in the same directory as the SAP2000 program files. Highlight
Sections.pro and click the Open button.

A dialog box appears with alist of all wide flange sections in the database. Inthis
dialog box:

» Scroll down and highlight the L4x4x3/4 by clicking on it.

» Hold down the Shift key on the keyboard and click on the L4x4x1/4 angle. All of
the L4x4 angles will now be selected (seven total).

» Click the OK button twice to return to the Define Frame sections dialog box.

Click the drop-down box that says Add I/Wide Flange and select the Add Auto Select
option to display the Auto Selection Sections dialog box.

In this dialog box:

» Highlight al of the anglesin the List of Sections list box by clicking on the top
angle, pressing and holding down the shift key on the keyboard, and clicking on the
bottom angle.

» Click the Add button to add the angles to the Auto selections list box.

» Click the OK button twice to exit all dialog boxes.

Click the drop down box in the status bar to change the units to kip-ft. [kip-# -l

From the Define menu select Shell Sections... to display the Define Shell Sections dialog
box.

In this dialog box:

Click the M odify/Show Section button to display the Shell Sections dialog box.

In this dialog box:

» Verify the Material specified is CONC.

» Inthe Thickness areatype .6667 in both the Membrane and Bending edit boxes.
» Verify that the Shell option is chosen in the Type area.

» Click the OK button twice to exit all dialog boxes.
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Click inthe 3D View window to make sure it is active.
Click the Select All button on the side toolbar to select al elements.

From the Assign menu select Frame and then Sections... from the submenu to display the
Define Frame Sections dialog box.

In this dialog box:

» Highlight the AUTOL1 section.

» Click the OK button.

Click the Select All button &ll| on the side toolbar to select all elements.

From the Assign menu select Shell Static Loads... and then Uniform... from the submenu
to display the Shell Uniform Loads dialog box.

In this dialog box:

» Veify DL isselected in the Load Case Name drop-down box.

* Inthe Uniform Load areatype -.05 (50 psf) in the Load edit box.

* Inthe Uniform Load area verify that the Dir item is set to Global Z.
» Click the OK button.

Click the Select All button &} on the side toolbar to select all elements.

From the Assign menu select Shell Static Loads... and then Uniform... from the submenu
to display the Shell Uniform Loads dialog box.

In this dialog box:

* Select LL inthe Load Case Name drop-down box.

* Inthe Uniform Load areatype -.1 (100 psf) in the Load edit box.
» Click the OK button.

Click the Show Undefor med Shape button g to remove the display of the shell static
loads.

Click in the window labeled X-Y Plane @ Z=37 to activate it.

Select all of the elements in the plan view by “windowing”
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From the Assign menu select Joints and then Constraints... from the submenu to display
the Constraints dialog box.

In this dialog box:

* IntheClick To areaclick the drop-down box that says Add Body and select Add
Diaphragm to display the Diaphragm Constraint dialog box.

* Inthisdialog box:
» Type ROOF in the Constraint Name edit box.
» Verify that the Z Axis option is selected in the Constraint Axis area.
» Click the OK button twice to exit all dialog boxes.

Click the Show Undefor med Shape button g to remove the display of the joint
constraints and reset the window display.

Click the Down One Gridline button |i| to move to the X-Y Plane @ Z=25.
Select all of the elements in the plan view by “windowing”

From the Assign menu select Joints and the Constraints... from the submenu to display the
Constraints dialog box.

In this dialog box:

* Inthe Click To area click the drop-down box that says Add Body and select Add
Diaphragm to display the Diaphragm Constraint dialog box.

* In this dialog box:
» TypeSECOND in the Constraint Name edit box.
» Verify that the Z Axis option is selected in the Constraint Axis area.
» Click theOK button twice to exit all dialog boxes.

Click the Show Undeformed Shape buttong to remove the display of the joint
constraints and reset the window display.

From theAnalyze menu selecBet Options... to display the Analysis Options dialog box.
* Check the Dynamic Analysis check box.

* Click theSet Dynamic Parameters button to display the Dynamic Analysis
Parameters dialog box.
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* Inthisdialog box:
» Type 3 inthe Number of Modes edit box.
» Click the OK button twice to exit all dialog boxes.
From the Options menu select Preferences... to display the Preferences dialog box.
In this dialog box:
» Select the Stedl Tab.
» Select AISC-ASD89 from the Steel Design Code drop-down box.
» Click the OK button.
Click the Run Analysis button _»| to run the analysis.

When the analysis is complete check the messages in the Analysis window (there should be
no warnings or errors) and then click the OK button to close the Analysis window.

From the Design menu select Start Design/Check of Structureto initiate the design. The
design proceeds and when it is complete P-M interaction ratios are displayed.

Click the Set Elements button|§| on the main toolbar (or select Set Elements.. from the
View menu) to display the Set Elements Dialog box.

In this dialog box:
»  Check the Sections box in the Frames area.
* Click the OK button. The sections chosen by the program are displayed.

Note: You may want to zoomin using the Rubber Band Zoom button @8] on the main
toolbar to see the chosen sections better.

Click the Show Undeformed Shapdutton g to remove the display of frame sections
and interaction values.

If you have zoomed in for a better view of the chosen sections, then click the Restore Full
View button| @] on the main toolbar.

Click the Select Allbutton on the side toolbar to select al elements.

From the Designmenu select Replace Auto W/ Optimal Sectiongo update the frame
sections from Auto sections to the chosen angle sizes. Click OK when it says it will
unlock the model and asks if it is OK to update.

Click the Run Analysis button _»| to run the analysis using the optimal sections.
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When the analysis is complete check the messages in the Analysis window (there should be
no warnings or errors) and then click the OK' button to close the Analysis window. Note
that the 3-D window now shows the first mode shape.

Click the Start Animation button | StartAnimation |, located in the status bar a the
bottom of the SAP2000 window, to animate the mode shape.

Click the Right Arrow button|/= |, located in the status bar at the bottom of the screen, to
view the second mode shape.

Click the Right Arrow button|/= | again to view the third mode shape.

Click the Stop Animation button [ Stérimaion |, located in the status bar a the bottom of
the SAP2000 window, to stop the mode shape animation.

From the Design menu select Start Design/Check of Structureto initiate afinal design
check of the structure based on the analysis results using the optimal sections. The design
proceeds and when it is complete the final P-M interaction ratios are displayed.
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