Problem S

Finite Element Model of Steel Beam With Web Openings

Steel
E =29000 ksi
Poissons Ratio = 0.3
Built-Up Beam: d =40 in
t,=0.75in
b=16in
t=2in
Beam openings are 20" high by 48” wide centered over the
depth of the beam

To Do

Construct a finite element model of this simply supported beam using shell
elements. Detemine moments and shears at center of beam and at center
of left opening. Plot shear stresses (S12) in beam web.
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Note: Our intent isthat you try this problem on your own first. After you have solved it on your
own, you can step through our solution if desired. If you have problemstrying to create the
model, then follow the stepsin our solution.



Problem S Solution

1.  Click the drop down box in the status bar to change the units to kip-in. [ip-in -

2. Fromthe File menu select New Model.... This displays the Coordinate System Definition
dialog box.

3. Inthisdialog box
» Select the Cartesian Tab.
* Inthe Number of Grid Spaces areatype 1 inthe X direction edit box.
* Inthe Number of Grid Spaces areatype 2 inthe Y direction edit box.
* Inthe Number of Grid Spaces areatype 1 in the Z direction edit box.
* Inthe Grid Spacing areatype 240in the X direction edit box.
* Inthe Grid Spacing areatype 8 inthe Y direction edit box.
* Inthe Grid Spacing areatype 40 in the Z direction edit box.
» Click the OK button.

4.  Click in the window titled X-Y Plane @ Z=40 to make sure it is active. The window is
highlighted when it isactive. The screen appears as shown in Figure S-1.

5. Click the Draw Rectangular Shell Elemembuttonﬂ on the side toolbar or select Draw
Rectangular Shell Elementfrom the Draw menu.

6. Click on the point labeled “A” and then the point labeled “B” in Figure S-1 to enter a shell

element.
Mezh Selected Shells

7. Click thePointer buttor [;| to exit Draw Mode

and enter Select Mode.
' Mesh inta i“ﬁa“““
8. Click on the shell element to select it. by ,2— Chells
9. From theEdit menu selecM esh Shells... to € Mesh using sslected Jaints on edges
display the Mesh Selected Shells dialog box. T Mesh at intersection with grids

10. Fill in this dialog box as shown in the adjacent Cancel_|

figure and click théOK button.

11. Click the Select All button on the side toolbar to select all elements.
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Figure S-1: Screen After Step 4

12.  Fromthe Edit menu select Copy.
13. Fromthe Edit menu select Paste...to display the Paste Coordinates dialog box.
14. Inthisdialog box:

* Type-40inthe DeltaZ edit box.

» Click the OK button.

15. Click inthe window titled X-Y Plane @ Z=40 to make sureit is active. Do not
accidentally select any elements while doing this.

16. Fromthe View menu select Set 2D View...to display the Set 2D View dialog box.
17. Inthisdialog box:
» Select the X-Z Plane option.

* TypeOinthe Y= edit box.



* Click the OK button. The screen appears as shown in Figure S-2.
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Figure S-2: Screen After Step 17

18. Click the Draw Rectangular Shell Element buttonE‘ on the side toolbar or select Draw
Rectangular Shell Element from the Draw menu.

19. Click on the point labeled “A” and then the point labeled “B” in Figure S-2 to enter a shell

element. Mesh Selected Shells

20. Click thePointer buttor [3| to exit Draw Mode
¥ Meshinto i2EI

and enter Select Mode.

. . 14
21. Click on the shell element to select it. . Shells
' Mezh uzing selected Joints on edges
22. From theEdit menu selec esh Shdlls... to ™ Mesh at intersection with grids

display the Mesh Selected Shells dialog box.

k. I Cancel

23. Fillin this dialog box as shown in the adjacent
figure and click théOK button.

24. Click in the window titled 3-D View to make sure it is active.



25.

26.

27.

28.

29.

30.
31.

32.

33.
34.
35.
36.
37.

Click the Select All button on the side toolbar to select al elements.

From the Edit menu select Change Labels...to display the Relabel Selected items dialog
box.

In this dialog box:

» Typelinthe Joint Next Number edit box.
» Type 1l inthe Shell Next Number edit box.
* Click the OK button.

Note: It isnot necessary to change relabel the elements. We are doing it here to assure
that later on in the solution when we refer to element labels that everybody has the
same labeling system.

Click the Set Elementsbutton|§| on the main toolbar (or select Set Elements.. from the
View menu) to display the Set Elements Dialog box.

In this dialog box:

» Check the Fill Elements box.

» Click the OK button.

Click in the window titled X-Z Plane @ Y =0 to make sure it is active.

Click the Set Elementsbutton|§| on the main toolbar (or select Set Elements.. from the
View menu) to display the Set Elements Dialog box.

In this dialog box:

» Check the Labels box in the Shells area.

» Check the Fill Elements box.

» Click the OK button.

Select shell elements 65, 66, 67, 68, 85, 86, 87 and 88 by “windowing”.
Press the Delete key on the keyboard to delete these shell elements.
Select shell elements 73, 74, 75, 76, 93, 94, 95 and 96 by “windowing”.
Press the Delete key on the keyboard to delete these shell elements.

Click theRefresh Window buttor #| on the main toolbar to refresh the view.



38.
39.
40.

41.

42.

43.

45.

46.

47.

48.

Click in the window titled 3-D View to make sure it is active.
Click the Refresh Window button ¢ | on the main toolbar to refresh the view.
Click in the window titled X-Z Plane @ Y =0 to make sure it is active.

Click the Set Elements button|§| on the main toolbar (or select Set Elements.. from the
View menu) to display the Set Elements Dialog box.

In this dialog box:

» Check the Labels box in the Joints area.

» Uncheck the Labels box in the Shells area.

» Click the OK button.

Select joint 22 (lower left-hand corner) by clicking on it.

From the Assign menu, choose Joint, and then Restraints...from the submenu. Thiswill
display the Joint Restraints dialog box.

In this dialog box:
* Veify that the Translation 1 and Translation 3 boxes are checked.
» Uncheck the Translation 2 box.

» Veify that the Rotation About 1, Rotation About 2 and Rotation About 3 boxes are not
checked.

» Click the OK button.
Select joint 42 (lower right-hand corner) by clicking on it.

From the Assign menu, choose Joint, and then Restraints...from the submenu. Thiswill
display the Joint Restraints dialog box.

In this dialog box:

» Uncheck the Translation 1 box.

» Veify that the Translation 2 box is not checked.
* Veify that the Translation 3 box is checked.

» Veify that the Rotation About 1, Rotation About 2 and Rotation About 3 boxes are not
checked.



49.

50.

Sl

52.
53.

54.

55.

56.

S7.

58.

59.

60.

» Click the OK button.
Select joints 148 and 168 (upper left-hand and right-hand corners) by clicking on them.

From the Assign menu select Joint Static L oads... and then For ces... from the submenu to
display the Joint Forces dialog box.

In this dialog box:

* Type-9inthe Force Global Z edit box in the Loads area.
» Click the OK button.

Select joints 149 through 167 by “windowing”.

From theAssign menu selecioint Static Loads... and therforces... from the submenu to
display the Joint Forces dialog box.

In this dialog box:
* Type-18in the Force Global Z edit box in the Loads area.
* Click theOK button.

Click the Show Undefor med Shape buttong to remove the display of joint force
assignments.

From theDefine menu selecM aterials... to display the Define Materials dialog box.

Highlight the STEEL material and click thdodify/Show M aterial button to display the
Material Property Data dialog box.

In this dialog box:

» Verify that the Modulus of Elasticity is 29000.

» Verify that Poisson’s ratio is 0.3.

* Click theOK button twice to exit the dialog boxes.

From theDefine menu selecBhell Sections... to display the Define Shell Sections dialog
box.

In this dialog box:
» Click theAdd New Section button to display the Shell Sections dialog box.

* In this dialog box:



61.
62.

63.

65.

66.

67.

Type WEB in the Section Name edit box.
Select STEEL from the Material drop-down box.
In the Thickness area type .75 in both the Membrane and Bending edit boxes.

Verify that the Shell option is chosen in the Type area.
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Click the OK button to return to the Define Shell Sections dialog box.
» Click the Add New Section button to display the Shell Sections dialog box.
* Inthisdialog box:
» Type FLANGE in the Section Name edit box.
» Select STEEL from the Material drop-down box.
» Inthe Thickness areatype 2 in both the Membrane and Bending edit boxes.
» Verify that the Shell option is chosen in the Type area.
» Click the OK button twice to exit all dialog boxes.
Click the Select All button [&ll| on the side toolbar to select all elements.

From the Assign menu select Shell and then Sections...to display the Define Shell
Sections dialog box.

In this dialog box:

» Highlight FLANGE in the Shell Sections area by clicking on it.

» Click the OK button.

Select all of the elements in the X-Z Plane @ Y=0 window by “windowing”.

From theAssign menu selecBhell and therSections...to display the Define Shell
Sections dialog box.

In this dialog box:
» Highlight WEB in the Shell Sections area by clicking on it.
» Click the OK button.

Click the Show Undeformed Shapdutton g to remove the display of shell section
assignments.



68.
69.
70.

71.

72.

73.

74.

75.

76.

7.
78.
79.
80.

Click in the window titled X-Z Plane @ Y =0 to make sure it is active.

From the View menu select Set Limits... to display the Set Limits dialog box.
In this dialog box:

* Inthe Set X AxisLimitsareatype-12inthe Min edit box.

* Inthe Set X AxisLimitsareatype O in the Max edit box.

» Click the OK button.

Click the Perspective Toggléutton | @ on the main toolbar. A perspective view of the
X-Z elevation is displayed.

Click the Rubber Band Zoombutton (& |on the main toolbar and zoom in on the view by
“drawing” a window tightly around it.

Select all of the joints on the right side of the section by “windowing”.

Click the Set Intersecting Line Select M ode buttoni#| and select all of the shell elements
by “drawing” a line through them. There should now be 9 joints and 8 shells selected.
You can verify this by looking at the left-hand side of the status bar at the bottom of the
SAP2000 window.

From theAssign menu selecGroup Name... to display the Assign Group dialog box.
In this dialog box:

* Type CENTER inthe Groups edit box.

» Click the Add New Group Namebutton.

» Click the OK button.

Click the Show Undeformed Shapéutton g to reset the limits of the display.
From the View menu select Refresh Viewto rescale the view.

From the View menu select Set Limits... to display the Set Limits dialog box.
In this dialog box:

* Inthe Set X Axis Limits areatype -60 in the Min edit box.

* Inthe Set X Axis Limits areatype -48 in the Max edit box.

e Click the OK button.



81.

82.

83.

84.
85.

86.

87.

88.
89.

90.
91.

92.

93.

Click the Rubber Band Zoom button (& |on the main toolbar and zoom in on the view by
“drawing” a window tightly around it.

Select all of the joints on the right side of the section by “windowing”.

Click the Set Intersecting Line Select M ode buttoni#| and select all of the shell elements
by “drawing” a line through them. There should now be 8 joints and 6 shells selected.
You can verify this by looking at the left-hand side of the status bar at the bottom of the
SAP2000 window.

From theAssign menu selecGroup Name... to display the Assign Group dialog box.
In this dialog box:

* TypeLEFT inthe Groups edit box.

» Click the Add New Group Namebutton.

» Click the OK button.

Select all of the joints on the right side of the top half of the section by “windowing”.

Click the Set Intersecting Line Select M ode buttoni#| and select all of the shell elements

in the top half by “drawing” a line through them. There should now be 4 joints and 3 shells
selected. You can verify this by looking at the left-hand side of the status bar at the bottom
of the SAP2000 window.

From theAssign menu selecGroup Name... to display the Assign Group dialog box.

In this dialog box:

 TypeLEFTTOP inthe Groups edit box.

» Click the Add New Group Namebutton.

» Click the OK button.

Select all of the joints on the right side of the bottom half of the section by “windowing”.

Click the Set Intersecting Line Select M ode button | and select all of the shell elements
in the bottom half by “drawing” a line through them. There should now be 4 joints and 3
shells selected. You can verify this by looking at the left-hand side of the status bar at the
bottom of the SAP2000 window.

From theAssign menu selecGroup Name... to display the Assign Group dialog box.
In this dialog box:

 TypeLEFTBOT inthe Groups edit box.
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94.
95.
96.

97.

98.

99.

100.

101.

102.

103.

104.

» Click the Add New Group Name button.

» Click the OK button.

Click the Show Undeformed Shape button g to reset the limits of the display.
From the View menu select Refresh View to rescale the view.

Click the Set Elements button|§| on the main toolbar (or select Set Elements.. from the
View menu) to display the Set Elements Dialog box.

In this dialog box:
e Uncheck the Labels box in the Joints area.
e Click the OK button.

Click on the xz 2D Viewbutton| x| on the main toolbar to return from the perspective view
to a2-D view. Notethetitle of the window is X-Z Plane @ Y =0.

Click the “X” in the upper right-hand corner of the 3-D View window to close it.

From theAnalyze menu selecBet Options... to display the Analysis Options dialog box.

* In this dialog box click th&lane Frame XZ Plane buttor to set the

available degrees of freedom.

* Click theOK button.
Click theRun Analysis button__| to run the analysis.

When the analysis is complete check the messages in the Analysis window (there should be
no warnings or errors) and then click tB& button to close the Analysis window.

From theDisplay menu selecBhow Group Joint Force Sums..to display the Select
Groups dialog box.

In this dialog box:
» Click on CENTER to highlight it.

* Holding down the Shift key on the keyboard click on LEFTTOP to highlight it. All of
the groups except the default ALL should now be highlighted.

» Click the OK button to display the Group Joint Force Summation window and view the
group joint force sums. When finished viewing the group joint force sums, click the
“X” in the top right-hand corner of the Group Joint Force Summation window to close
it.
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105. From the Display menu select Show Element For ces/Stresses and then Shells...from the
submenu to display the Element Force/Stress Contours For Shells dialog box.

106. In thisdialog box:

» Click the Stresses option button to select it.

In the Component area click the S12 option button to select it.
* Inthe Stress Averaging area verify that the At All Joints option is selected.
» Check the Display on Deformed Shape check box.

» Click the OK button to display the shell stresses. The screen should look similar to that
in Figure S-3.

SAP2000 - 5 HE R

Fle Edit View Define Draw Select Assign Analyze Display Cesign Options Help

olslal || slfa | 8lel|e(elm| svle|e|s| sla] ¢[o| olals|s|s|s|el
IE ¥ Stess 512 Diagram  (LDAD1] | _ (Ol x]
3

=

l= |+ |= |+ g0 2|

4.40

T -3 20 .10 0.00

Riight Click on arw Shell Element for detailed diagram | Start Animation I #‘I = IK\p-in j

Figure S-3: Shell Stresses
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