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Note:  Our intent is that you try this problem on your own first.  After you have solved it on your
own, you can step through our solution if desired.  If you have problems trying to create the
model, then follow the steps in our solution.

Problem U
Barrel Vaulted Structure

Concrete
E =3600 ksi
Poissons Ratio = 0.2
12" thick concrete walls 
and slabs

To Do
Determine the maximum deflection 
at the center of upper and lower 
barrel vaults due to the self weight
of the structure.  Also determine  
the maximum deflection at center 
of upper and lower barrel vaults
due to the self weight plus the 
prescribed live load applied to the 
top barrel vault.  

10
’

10
’

5’

Barrel vault with
20' radius and 35° 
roll down angle 

Barrel vault with
30' radius and 35°
roll down angle

Live Load = 300 psf downward

40
’
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Problem U Solution

1. Click the drop down box in the status bar to change the units to kip-ft.

2. From the File menu select New Model From Template…. This displays the Model
Templates dialog box.

3. In this dialog box click on the Barrel  template                      button to display the Barrel
dialog box.

4. In this dialog box:

• Accept the default Number of Circumferential Spaces, 8.

• Accept the default Number of Span Spaces, 8.

• Type 40 in the Span edit box.

• Type 20 in the Radius edit box.

• Type 35 in the Roll Down Angle edit box.

• Uncheck the Restraints check box.

• Click the OK  button.

5. Click in the 3-D View window to make sure it is active.  The window is highlighted when
it is active.

6. Click the Select All button        located on the side toolbar to select the entire structure.

7. From the Edit  menu select Move… to display the Move Selected Points dialog box.

8. In this dialog box:

• Type 10 in the Delta Z edit box.

• Click the OK  button.

9. From the Edit  menu select Add To Model From Template… to display the Model
Templates dialog box.

10. In this dialog box click on the Barrel  template                      button to display the Barrel
dialog box.

11. In this dialog box:
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• Accept the default Number of Circumferential Spaces, 8.

• Accept the default Number of Span Spaces, 8.

• Type 40 in the Span edit box.

• Type 30 in the Radius edit box.

• Type 35 in the Roll Down Angle edit box.

• Uncheck the Restraints check box if it is not already unchecked.

• Click the Advanced button.

À Type 25 in the Z edit box in the Translations area.

À Click the OK button twice to exit all dialog boxes.

12. Click in the Y-Z Plane @ X=20 window to make sure it is active.

13. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

14. In this dialog box:

• Check the Labels box in the Joints area.

• Click the OK button.

15. Right click on joint 154 in window with the Y-Z Plane @ X=20.  The Joint Information
dialog box is displayed.

16. Highlight the Y-coordinate (-17.2073) and press the Ctrl and the C keys on the keyboard at
the same time to copy the value to the clipboard.

17. Click the Cancel button to close the Joint Information dialog box.

18. From the Edit menu select Add To Model From Template… to display the Model
Templates dialog box.

19. In this dialog box click on the Shear Wall template                     button to display the Shear
Wall dialog box.

20. In this dialog box

• Type 8 in the Number of Spaces Along X edit box.

• Type 4 in the Number of Spaces Along Z edit box.
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• Type 5 Space Width Along X edit box.

• Type 2.5 Space Width Along Z edit box.

• Uncheck the Restraints check box if it is not already unchecked.

• Click the Advanced button.

À Highlight the Y edit box and press the Ctrl and the V keys on the keyboard at the
same time to paste the -17.2073 value from the clipboard.

À Type 15 in the Z edit box in the Translations area.

À Click the OK button twice to exit all dialog boxes.

21. Right click on joint 73 in window with the Y-Z Plane @ X=20.  The Joint Information
dialog box is displayed.

22. Highlight the Y-coordinate (-11.4715) and press the Ctrl and the C keys on the keyboard at
the same time to copy the value to the clipboard.

23. Click the Cancel button to close the Joint Information dialog box.

24. From the Edit menu select Add To Model From Template… to display the Model
Templates dialog box.

25. In this dialog box click on the Shear Wall template                     button to display the Shear
Wall dialog box.

26. In this dialog box

• Type 8 in the Number of Spaces Along X edit box.

• Type 4 in the Number of Spaces Along Z edit box.

• Type 5 Space Width Along X edit box.

• Type 2.5 Space Width Along Z edit box.

• Uncheck the Restraints check box if it is not already unchecked.

• Click the Advanced button.

À Highlight the Y edit box and press the Ctrl and the V keys on the keyboard at the
same time to paste the -11.4715 value from the clipboard.

À Click the OK button twice to exit all dialog boxes.

27. Click the Pointer button       on the side tool bar to enter select mode.
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28. Click in the Y-Z Plane @ X=20 window to make sure it is active.

29. From the View menu select Set 2D View… to display the Set 2D View dialog box.

30. In this dialog box:

• Select the X-Z Plane option.

• Type -11.4715 in the Y= edit box.

• Click the OK  button.

31. Select all of the elements in this view by “windowing”

32. From the View menu select Set 2D View… to display the Set 2D View dialog box.

33. In this dialog box:

• Select the X-Z Plane option.

• Type -17.2073 in the Y= edit box.

• Click the OK  button.

34. Select all of the elements in this view by “windowing”

35. From the View menu select Show Selection Only.

36. Click the Perspective Toggle button        on the main toolbar.

37. From the View menu select Show Grid to toggle the grids off.

38. From the View menu select Show Axes to toggle the axes off.

39. From the Draw menu select Draw Quad Shell Element.

40. In the X-Z perspective view click on joints 163,
195, 73 and 1, in that order, to draw a shell
element.

41. Click the Pointer button       on the side tool bar
to exit draw mode and enter select mode.

42. Click on the just drawn shell element to select it.

43. From the Edit menu select Mesh Shells… to
display the Mesh Selected Shells dialog box.

44. Fill in this dialog box as shown in the figure and
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click the OK button.

Note:  It is difficult to figure out whether to mesh shells 3 by 8 or 8 by 3.  It is often easiest
to just go ahead and try one way, and if it isn’t right, simply click the Undo button
on the main toolbar and mesh the shells the other way.

45. Select all of the elements in the X-Z perspective view by “windowing”.

46. From the Edit menu select Replicate… to display the Replicate dialog box.

47. In this dialog box:

• Select the Mirror Tab.

• In the Mirror About area select the XZ Plane option.

• In the Ordinate area type 0 in the Y edit box if it is not already there.

• Click the OK  button.

48. From the View menu select Set 2D View… to display the Set 2D View dialog box.

49. In this dialog box:

• Select the X-Y Plane option.

• Type 0 in the Z= edit box.

• Click the OK  button.

50. Select all of the joints at this level by “windowing”.

51. From the Assign menu select Joint and then Restraints… from the submenu to display the
Joint Restraints dialog box.

52. In this dialog box:

• Verify that the Translation 1, 2 and 3 boxes are all checked.

• Click the OK button.

53. From the View menu select Set 2D View… to display the Set 2D View dialog box.

54. In this dialog box:

• Select the Y-Z Plane option.

• Type 20 in the X= edit box.
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• Click the OK button.

55. Click the Show Undeformed Shape button        to reset the window title.

56. From the View menu select Show All.

57. Click the drop down box in the status bar to change the units to kip-in.

58. From the Define menu select Materials... to display the Define Materials dialog box.

59. Click on CONC in the Materials area to highlight (select) it, and then click the
Modify/Show Material button.  The Material Property Data dialog box is displayed.

60. In this dialog box:

• Type 3600 in the Modulus of Elasticity edit box.

• Verify .2 is entered in the Poisson’s Ratio edit box.

• Click the OK button twice to exit all dialog boxes.

61. Click the drop down box in the status bar to change the units to kip-ft.

62. From the Define menu select Materials... to display the Define Materials dialog box.

63. Click on CONC in the Materials area to highlight (select) it, and then click the
Modify/Show Material button.  The Material Property Data dialog box is displayed.

64. In this dialog box:

• Verify that 4.657E-03 is entered in the Mass Per Unit Volume edit box.

• Verify that .15 is entered in the Weight Per Unit Volume edit box.

• Click the OK button twice to exit all dialog boxes.

65. From the Define menu select Shell Sections... to display the Define Shell Sections dialog
box.

66. In this dialog box:

• Click the Modify/Show Section button to display the Shell Sections dialog box.

• In this dialog box:

À Verify that the Material is CONC.

À Verify that both the Membrane and Bending thicknesses are 1.
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À Verify that the Shell option is chosen in the Type area.

À Click the OK button twice to exit all dialog boxes.

67. From the Define menu select Static Load Cases... to display the Define Static Load Case
Names dialog box.

68. In this dialog box:

• Type DL in the Load edit box.

• Click the Change Load button.

• Type LL in the Load edit box.

• Select Live from the Type drop-down box.

• Type 0 in the Self Weight Multiplier edit box.

• Click the Add New Load button.

• Click the OK button.

69. From the Define menu select Load Combinations... to display the Define Load Case
Combinations dialog box.

70. In this dialog box:

• Click the Add New Combo button to display the Load Combination Data dialog box..

• In this dialog box:

À Accept the default Load Combination Name COMB1.

À Accept the default Load Combination Type, Add.

À Type COMB1:  DL + LL in the Title edit box.

À Verify that DL Load Case appears in the Case Name drop-down box, and that the
Scale Factor is 1.

À Click the Add button.

À Select LL Load Case from the Case Name drop-down box

À Click the Add button.

À Click OK twice to exit all dialog boxes.
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71. Click in the 3-D View window to activate it.  Be careful not to accidentally select any
members when you do this.

72. From the View menu select Set Limits… to display the Set Limits dialog box.

73. In this dialog box:

• Type 25 in the Min edit box in the Set Z Axis limits area.

• Click the OK button.

74. Select all of the displayed elements in the 3D View window (i.e., all elements in the roof
barrel) by “windowing”.

75. From the Assign menu choose Shell Static Loads… and then choose Uniform…  from the
submenu to display the Shell Uniform Loads dialog box.

76. In this dialog box:

• Select LL from the Load Case Name drop-down box.

• Type -.3 in the Load edit box.

• Verify that Global Z is selected in the Dir drop-down box.

• Click the OK  button.

77. Click the Show Undeformed Shape button        to remove the display of shell uniform
loads and to remove the limits that were set.

78. Click the Run Analysis button      to run the analysis.

79. When the analysis is complete check the messages in the Analysis window (there should be
no warnings or errors) and then click the OK  button to close the Analysis window.

80. Click in the window titled Y-Z Plane @ X=20 to activate it.

81. Click the Display Static Deformed Shape button        on the main toolbar to display the
Deformed Shape dialog box.

82. In this dialog box:

• Select the DL Load Case from the Load drop-down box.

• Select the Auto Scaling option.

• Click the OK  button.

83. Click the drop down box in the status bar to change the units to kip-in.
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84. Right click on the center joint of the upper barrel vault to see its self weight displacement
in inches.

85. Right click on the center joint of the lower barrel vault to see its self weight displacement
in inches.

86. Click the Display Static Deformed Shape button        on the main toolbar to display the
Deformed Shape dialog box.

87. In this dialog box:

• Select the COMB1 Combo from the Load drop-down box.

• Click the OK button.

88. Right click on the center joint of the upper barrel vault to see its self weight plus live load
displacement in inches.

89. Right click on the center joint of the lower barrel vault to see its self weight plus live load
displacement in inches.

Alternative Problem U Solution

Now an alternative method of creating the model is shown.  This alternative method does not use
the Advanced button feature of the Add To Model From Template feature.  Instead it makes
use of groups and the move command to accomplish essentially the same thing.  It is a good
example of one of the uses of groups.  This alternative method takes more steps than the initial
method shown.  The initial method is recommended; this method is just shown for example
purposes.

A1. Click the drop down box in the status bar to change the units to kip-ft.

A2. From the File menu select New Model From Template…. This displays the Model
Templates dialog box.

A3. In this dialog box click on the Barrel Template                      button to display the Barrel
dialog box.

A4. In this dialog box

• Accept the default Number of Circumferential Spaces, 8.

• Accept the default Number of Span Spaces, 8.
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• Type 40 in the Span edit box.

• Type 20 in the Radius edit box.

• Type 35 in the Roll Down Angle edit box.

• Uncheck the Restraints check box.

• Click the OK button.

A5. Click in the 3-D View window to make sure it is active.  The window is highlighted when
it is active.

A6. Click the Select All button        located on the side toolbar to select the entire structure.

A7. From the Assign menu select Group Name... to display the Assign Group dialog box.

A8. In this dialog box:

• Type LOBARREL in the Groups edit box.

• Click the Add New Group Name button.

• Click the OK button.

A9. Click the Restore Previous Selection button          on the side toolbar (or select Get
Previous Selection from the Select menu).

A10. From the Edit menu select Move… to display the Move Selected Points dialog box.

A11. In this dialog box:

• Type 10 in the Delta Z edit box.

• Click the OK  button.

A12. From the Edit  menu select Add To Model From Template… to display the Model
Templates dialog box.

A13. In this dialog box click on the Barrel  template                      button to display the Barrel
dialog box.

A14. In this dialog box

• Accept the default Number of Circumferential Spaces, 8.

• Accept the default Number of Span Spaces, 8.

• Type 40 in the Span edit box.
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• Type 30 in the Radius edit box.

• Type 35 in the Roll Down Angle edit box.

• Uncheck the Restraints check box if it is not already unchecked.

• Click the OK button.

A15. Click the Pointer button       on the side tool bar to enter select mode.

A16. Click the Select All button        located on the side toolbar to select the entire structure.

A17. From the Select menu choose Deselect and then choose Groups… from the submenu to
display the Select Groups dialog box.

A18. In this dialog box:

• Click on the LOBARREL group to highlight it.

• Click the OK  button.

A19. From the Assign menu select Group Name... to display the Assign Group dialog box.

A20. In this dialog box:

• Type HIBARREL  in the Groups edit box.

• Click the Add New Group Name button.

• Click the OK  button.

A21. Click the Restore Previous Selection button          on the side toolbar (or select Get
Previous Selection from the Select menu).

A22. From the Edit  menu select Move… to display the Move Selected Points dialog box.

A23. In this dialog box:

• Type 25 in the Delta Z edit box.

• Click the OK  button.

A24. From the Edit  menu select Add To Model From Template… to display the Model
Templates dialog box.

A25. In this dialog box click on the Shear Wall template                     button to display the Shear
Wall dialog box.

A26. In this dialog box
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• Type 8 in the Number of Spaces Along X edit box.

• Type 4 in the Number of Spaces Along Z edit box.

• Type 5 Space Width Along X edit box.

• Type 2.5 Space Width Along Z edit box.

• Uncheck the Restraints check box if it is not already unchecked.

• Click the OK button.

A27. Click the Pointer button       on the side tool bar to enter select mode.

A28. Click the Select All button        located on the side toolbar to select the entire structure.

A29. From the Select menu choose Deselect and then choose Groups… from the submenu to
display the Select Groups dialog box.

A30. In this dialog box:

• Click on the HIBARREL group to highlight it.

• Hold down on the Ctrl key on the keyboard and click on the LOBARREL group to add
it to the selection

• Click the OK  button.

A31. From the Assign menu select Group Name... to display the Assign Group dialog box.

A32. In this dialog box:

• Type WALL1  in the Groups edit box.

• Click the Add New Group Name button.

• Click the OK  button.

A33. Click in the Window titled Y-Z Plane @ X=20 to activate it.

A34. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

A35. In this dialog box:

• Check the Labels box in the Joints area.

• Click the OK  button.
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A36. Right click on joint 154.  The Joint Information dialog box is displayed.

A37. In this dialog box:

• Note that the Y-coordinate of this joint is -17.2073.

• Click the OK button to close the dialog box.

A38. From the Select menu choose Select and then choose Groups… from the submenu to
display the Select Groups dialog box.

A39. In this dialog box:

• Click on the WALL1 group to highlight it.

• Click the OK  button.

A40. From the Edit  menu select Move… to display the Move Selected Points dialog box.

A41. In this dialog box:

• Type -17.2073 in the Delta Y edit box.

• Type 15 in the Delta Z edit box.

• Click the OK  button.

A42. Right click on joint 73.  The Joint Information dialog box is displayed.

A43. In this dialog box:

• Note that the Y-coordinate of this joint is -11.4715.

• Note that the Y-direction distance between joints 154 and 73 can be calculated as
17.2073 - 11.4715 = 5.7358.

• Click the OK  button to close the dialog box.

A44. From the Select menu choose Select and then choose Groups… from the submenu to
display the Select Groups dialog box.

A45. In this dialog box:

• Click on the WALL1 group to highlight it.

• Click the OK  button.

A46. From the Edit  menu select Replicate… to display the Replicate dialog box.
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A47. In this dialog box:

• Select the Linear Tab.

• Type 5.7358 in the Y Distance edit box.

• Type -15 in the Z Distance edit box.

• Type 1 in the Number edit box.

• Click the OK button.

A48. Click the Select All button        located on the side toolbar to select the entire structure.

A49. From the Select menu choose Deselect and then choose Groups… from the submenu to
display the Select Groups dialog box.

A50. In this dialog box:

• Click on the HIBARREL group to highlight it.

• Hold down on the Ctrl key on the keyboard and click on the LOBARREL group to add
it to the selection

• Click the OK  button.

A51. From the View menu select Show Selection Only.

A52. From the View menu select Set 2D View… to display the Set 2D View dialog box.

A53. In this dialog box:

• Select the X-Z Plane option.

• Type -17.2073 in the Y= edit box.

• Click the OK  button.

A54. Click the Perspective Toggle button        on the main toolbar.

A55. From the View menu select Show Grid to toggle the grids off.

A56. From the Draw menu select Draw Quad Shell Element.

A57. In the X-Z perspective view click on joints 163, 203, 73 and 1, in that order, to draw a shell
element.
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A58. Click the Pointer button       on the side tool bar
to exit draw mode and enter select mode.

A59. Click on the just drawn shell element to select it.

A60. From the Edit menu select Mesh Shells… to
display the Mesh Selected Shells dialog box.

A61. Fill in this dialog box as shown in the figure and
click the OK  button.

Note:  It is difficult to figure out whether to mesh
shells 3 by 8 or 8 by 3.  It is often easiest to just go ahead and try one way, and if it
isn’t right, simply click the Undo button        on the main toolbar and mesh the shells
the other way.

A62. Select all of the elements in the X-Z perspective view by “windowing”.

A63. From the Edit menu select Replicate… to display the Replicate dialog box.

A64. In this dialog box:

• Select the Mirror Tab.

• In the Mirror About area select the XZ Plane option.

• In the Ordinate area type 0 in the Y edit box if it is not already there.

• Click the OK  button.

A65. From the View menu select Set 2D View… to display the Set 2D View dialog box.

A66. In this dialog box:

• Select the X-Y Plane option.

• Type 0 in the Z= edit box.

• Click the OK  button.

A67. Select all of the joints at this level by “windowing”.

A68. From the Assign menu select Joint and then Restraints… from the submenu to display the
Joint Restraints dialog box.

A69. In this dialog box:

• Verify that the Translation 1, 2 and 3 boxes are all checked.



17

• Click the OK button.

A70. From the View menu select Set 2D View… to display the Set 2D View dialog box.

A71. In this dialog box:

• Select the Y-Z Plane option.

• Type 20 in the X= edit box.

• Click the OK  button.

A72. Click the Show Undeformed Shape button        to reset the window title.

A73. From the View menu select Show All.

A74. Click the drop down box in the status bar to change the units to kip-in.

A75. From the Define menu select Materials... to display the Define Materials dialog box.

A76. Click on CONC in the Materials area to highlight (select) it, and then click the
Modify/Show Material  button.  The Material Property Data dialog box is displayed.

A77. In this dialog box:

• Type 3600 in the Modulus of Elasticity edit box.

• Verify .2 is entered in the Poisson’s Ratio edit box.

• Click the OK button twice to exit all dialog boxes.

A78. Click the drop down box in the status bar to change the units to kip-ft.

A79. From the Define menu select Materials... to display the Define Materials dialog box.

A80. Click on CONC in the Materials area to highlight (select) it, and then click the
Modify/Show Material button.  The Material Property Data dialog box is displayed.

A81. In this dialog box:

• Verify that 4.657E-03 is entered in the Mass Per Unit Volume edit box.

• Verify that .15 is entered in the Weight Per Unit Volume edit box.

• Click the OK button twice to exit all dialog boxes.

A82. From the Define menu select Shell Sections... to display the Define Shell Sections dialog
box.
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A83. In this dialog box:

• Click the Modify/Show Section button to display the Shell Sections dialog box.

• In this dialog box:

À Verify that the Material is CONC.

À Verify that both the Membrane and Bending thicknesses are 1.

À Verify that the Shell option is chosen in the Type area.

À Click the OK button twice to exit all dialog boxes.

A84. From the Define menu select Static Load Cases... to display the Define Static Load Case
Names dialog box.

A85. In this dialog box:

• Type DL in the Load edit box.

• Click the Change Load button.

• Type LL in the Load edit box.

• Select Live from the Type drop-down box.

• Type 0 in the Self Weight Multiplier edit box.

• Click the Add New Load button.

• Click the OK button.

A86. From the Define menu select Load Combinations... to display the Define Load Case
Combinations dialog box.

A87. In this dialog box:

• Click the Add New Combo button to display the Load Combination Data dialog box..

• In this dialog box:

À Accept the default Load Combination Name COMB1.

À Accept the default Load Combination Type, Add.

À Type COMB1:  DL + LL in the Title edit box.
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À Verify that DL Load Case appears in the Case Name drop-down box, and that the
Scale Factor is 1.

À Click the Add button.

À Select LL Load Case from the Case Name drop-down box

À Click the Add button.

À Click OK twice to exit all dialog boxes.

A88. Click in the 3-D View window to activate it.  Be careful not to accidentally select any
members when you do this.

A89. From the Select menu choose Select and then choose Groups… from the submenu to
display the Select Groups dialog box.

A90. In this dialog box:

• Click on the HIBARREL group to highlight it.

• Click the OK  button.

A91. From the Assign menu choose Shell Static Loads… and then choose Uniform…  from the
submenu to display the Shell Uniform Loads dialog box.

A92. In this dialog box:

• Select LL from the Load Case Name drop-down box.

• Type -.3 in the Load edit box.

• Verify that Global Z is selected in the Dir drop-down box.

• Click the OK  button.

A93. Click the Show Undeformed Shape button        to remove the display of shell uniform
loads.

A94. Click the Run Analysis button      to run the analysis.

A95. When the analysis is complete check the messages in the Analysis window (there should be
no warnings or errors) and then click the OK  button to close the Analysis window.

A96. Click in the window titled Y-Z Plane @ X=20 to activate it.

A97. Click the Display Static Deformed Shape button        on the main toolbar to display the
Deformed Shape dialog box.
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A98. In this dialog box:

• Select the DL Load Case from the Load drop-down box.

• Select the Auto Scaling option.

• Click the OK button.

A99. Click the drop down box in the status bar to change the units to kip-in.

A100. Right click on the center joint of the upper barrel vault to see its self weight displacement
in inches.

A101. Right click on the center joint of the lower barrel vault to see its self weight displacement
in inches.

A102. Click the Display Static Deformed Shape button        on the main toolbar to display the
Deformed Shape dialog box.

A103. In this dialog box:

• Select the COMB1 Combo from the Load drop-down box.

• Click the OK button.

A104. Right click on the center joint of the upper barrel vault to see its self weight plus live load
displacement in inches.

A105. Right click on the center joint of the lower barrel vault to see its self weight plus live load
displacement in inches.


